Autoscaling service degradation

Incident Report for Starburst Galaxy

Resolved

Our investigation revealed that the autoscaling has been working as expected -- with that we're closing this incident.
Posted Aug 14, 2025 - 18:30 UTC

Identified

We have identified an issue with the Galaxy Autoscaler where the recommendation engine is not detecting increased workloads (for scale-ups only, scale-downs are working as expected) which can lead to Trino clusters not being autoscaled to match the workload.

We recommend to scale up the clusters manually as we work towards a permanent fix.
Posted Aug 13, 2025 - 18:53 UTC
This incident affected: Clusters (AWS) (AWS ap-northeast1, AWS ap-southeast1, AWS ap-southeast2, AWS ca-central1, AWS eu-central1, AWS eu-west1, AWS eu-west2, AWS eu-west3, AWS us-east1, AWS us-east2, AWS us-west1, AWS us-west2), Clusters (Azure) (Azure centralindia, Azure eastus, Azure eastus2, azure francecentral, Azure southcentralus, Azure westeurope), and Clusters (GCP) (GCP asia-south1, GCP asia-southeast1, GCP europe-west2, GCP europe-west6, GCP southamerica-east1, GCP us-central1, GCP us-east1).