New Tables Created by Hive Connector After May 25 17:00 UTC With Double Slashes in Location Will Not Be Readable

Incident Report for Starburst Galaxy

Resolved

This incident has been resolved and we did not see any current customer impact.
Posted May 27, 2023 - 01:14 UTC

Monitoring

The fix has been deployed to all regions and the engineering team is monitoring the release.
Posted May 26, 2023 - 22:12 UTC

Update

We expect the issue to be fixed by 22:00 UTC.
Posted May 26, 2023 - 21:04 UTC

Update

We are continuing to work on a fix for this issue.
Posted May 26, 2023 - 21:00 UTC

Identified

We have identified the fix which should be rolled out by 22:00 UTC. The corruption should only impact newly created hive tables on AWS s3 with a double slash within the table location when creating a catalog.
Posted May 26, 2023 - 17:31 UTC

Update

We are continuing to investigate this issue.
Posted May 26, 2023 - 16:45 UTC

Investigating

We have identified an issue with Galaxy where new hive tables created can be corrupted on read. This would impact any tables created since May 25th, 17:00 UTC. We are working on a fix and will be applying once its been verified.
Posted May 26, 2023 - 14:21 UTC
This incident affected: Starburst Galaxy UI, Clusters (AWS) (AWS ap-northeast1, AWS ap-southeast1, AWS ap-southeast2, AWS ca-central1, AWS eu-central1, AWS eu-west1, AWS eu-west2, AWS eu-west3, AWS us-east1, AWS us-east2, AWS us-west1, AWS us-west2), Clusters (Azure) (Azure centralindia, Azure eastus, Azure eastus2, azure francecentral, Azure southcentralus, Azure westeurope), and Clusters (GCP) (GCP asia-south1, GCP asia-southeast1, GCP europe-west2, GCP europe-west6, GCP southamerica-east1, GCP us-central1, GCP us-east1).