Possible incorrect results when Galaxy Result Set Caching is enabled

Incident Report for Starburst Galaxy

Resolved

This has been resolved
Posted Mar 16, 2025 - 03:05 UTC

Monitoring

The fix has been deployed to production and we're monitoring the situation
Posted Mar 15, 2025 - 01:03 UTC

Update

The fix is almost ready - we expect to deploy it to production late Friday (Mar 14th).
Posted Mar 14, 2025 - 00:29 UTC

Identified

The issue has been identified. There was a bug with how results are serialized to the result set cache, which threw an exception that was not handled correctly. The team is working on a fix to handle the error case.
Posted Mar 13, 2025 - 18:08 UTC

Investigating

We are currently investigating a bug where query results are empty when result set caching is enabled on a cluster. This seems to affect certain catalog types, but not all. The team is investigating the root cause, but in the meantime if you're affected by this, please disable result set caching on your clusters.
Posted Mar 13, 2025 - 00:08 UTC
This incident affected: Starburst Galaxy UI.