This incident is now resolved. All impacted MCP calls should now be operating as expected.
Posted Sep 09, 2026 - 20:42 UTC
Update
We've identified an issue causing MCP tool calls to fail with a protocol error for Galaxy MCP users (both mcp-starburst and mcp-starburst-public, all auth methods). A fix is in progress.
Workaround (Claude Code users): setting "MCP_PROTOCOL_NEGOTIATION": "legacy" in ~/.claude/settings.json mitigates the issue. Other MCP clients (Gemini CLI, Cursor, Continue.dev, Cline) aren't currently affected, since they default to an older protocol revision.
Posted Sep 09, 2026 - 14:37 UTC
Identified
Starburst Galaxy's MCP server is returning an error for every tool call from MCP clients using the newest protocol revision, 2026-07-28. Sign-in, discovery and tool listing are unaffected, and clients on revision 2025-11-25 are not affected. Workaround: pin your MCP client to protocol revision 2025-11-25, which has been confirmed to restore tool calls. We are investigating and will post an update as soon as we have one.