PrivateLink connections issues

Incident Report for Starburst Galaxy

Resolved

This incident has been resolved.
Posted Aug 13, 2026 - 15:39 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 13, 2026 - 14:30 UTC

Identified

We are investigating an issue causing clusters and pipelines connected via AWS/Azure PrivateLink to fail to start, with queries timing out. Clusters using standard (non-PrivateLink) connectivity are not affected. Our team has identified the likely area (an Istio/networking change) and is working to confirm and remediate. We will post updates as we learn more.
Posted Aug 13, 2026 - 14:05 UTC
This incident affected: Clusters (AWS) (AWS ap-northeast1, AWS ap-southeast1, AWS ap-southeast2, AWS ca-central1, AWS eu-central1, AWS eu-west1, AWS eu-west2, AWS eu-west3, AWS us-east1, AWS us-east2, AWS us-west1, AWS us-west2).