Querying some Snowflake tables yields error `Failed fetching Arrow chunk`

Incident Report for Starburst Galaxy

Resolved

This incident has been resolved.
Posted Sep 13, 2025 - 22:52 UTC

Update

The fix has been deployed to production.
Posted Sep 11, 2025 - 21:10 UTC

Update

The fix was successfully tested in staging and is ready to be pushed into production soon.
Posted Sep 11, 2025 - 08:37 UTC

Monitoring

We are aware of some users getting the `Failed fetching Arrow chunk` error when querying Snowflake tables for larger result sets. We have a fix and are testing it in our staging environment. Production should receive this fix in a matter of hours.
Posted Sep 10, 2025 - 10:37 UTC