Query History Processing Delays

Incident Report for Starburst Galaxy

Resolved

This incident has been resolved.
Posted Feb 05, 2025 - 01:16 UTC

Monitoring

Query History delays are returning to normal status. We will continue to monitor to ensure Query History is operating normally.
Posted Feb 04, 2025 - 21:59 UTC

Identified

We've identified the issue and are working to reduce the delay between submitted queries and the query status shown in Galaxy. Queries are running as expected but taking longer than normal to appear in Query History.
Posted Feb 04, 2025 - 16:40 UTC

Update

We are still working to fix the issue where new queries take a long time to appear on the completed query list and completed queries display as "Running".
Posted Feb 04, 2025 - 15:57 UTC

Investigating

We are investigating a problem with query history, where new queries are slow to appear on the list. We are working on resolving the issue.
Posted Feb 04, 2025 - 14:29 UTC
This incident affected: Starburst Galaxy UI.