Elevated query failure rate for some customers

Incident Report for Starburst Galaxy

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 15, 2026 - 00:24 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 14, 2026 - 19:51 UTC

Investigating

We're investigating an issue causing intermittent query failures on fault-tolerant execution (FTE) queries. Affected queries fail with a GENERIC_INTERNAL_ERROR related to the Buffer Exchange Manager being unable to locate an expected data chunk mid-query. Retrying a failed query frequently succeeds.
Posted Sep 14, 2026 - 19:12 UTC
This incident affects: Clusters (AWS) (AWS ap-northeast1, AWS ap-southeast1, AWS ap-southeast2, AWS ca-central1, AWS eu-central1, AWS eu-west1, AWS eu-west2, AWS eu-west3, AWS us-east1, AWS us-east2, AWS us-west1, AWS us-west2), Clusters (Azure) (Azure centralindia, Azure eastus, Azure eastus2, azure francecentral, Azure southcentralus, Azure westeurope), and Clusters (GCP) (GCP asia-south1, GCP asia-southeast1, GCP europe-west2, GCP europe-west6, GCP southamerica-east1, GCP us-central1, GCP us-east1).