Password resets and account signups are degraded.
Incident Report for Starburst Galaxy
Resolved
The incident has been resolved.
Posted Feb 21, 2023 - 20:32 UTC
Monitoring
The issue is due to performance degradation with a vendor, Mailgun (https://status.mailgun.com). Password resets and account signups might take longer than expected. We are monitoring the situation and will follow up with updates.
Posted Feb 21, 2023 - 14:42 UTC
This incident affected: Starburst Galaxy UI.