Degraded performance when starting or scaling Galaxy clusters in AWS us-east-1
Incident Report for Starburst Galaxy
Resolved
We’ve restored Galaxy us-east-1 to full availability.
Posted Sep 28, 2023 - 22:24 UTC
Monitoring
We have restored normal operation in the AWS us-east-1 region through workarounds to mitigate the ongoing AWS issue. We will continue to monitor.
Posted Sep 28, 2023 - 20:30 UTC
Update
We are continuing to investigate this issue.
Posted Sep 28, 2023 - 20:23 UTC
Investigating
We’re currently experiencing degraded performance when starting or scaling Galaxy clusters in the AWS us-east-1 region. The root cause is AWS experiencing errors and increased delays in network propagation for newly launched EC2 instances in that region.
Posted Sep 28, 2023 - 20:05 UTC
This incident affected: Clusters (AWS) (AWS us-east1).